Problemas con dominio en url

Hola como están.

Tengo problemas con una url en nginx después de configurar los virtuales.

Tengo corriendo iredmail y odoo en el mismo webservices (nginx).

La instalación de iredmail me configuro nginx por defecto, levanta el webmail en dominio.com/web y el admin en dominio.com/admin.

Ahora el tema lo tengo cuando instale odoo, si levanto la url por el ip levanta sin problema pero cuando quiero levantarla por el nombre de dominio se me va al webmail de iredmail.

Cree un virtual en /etc/nginx/site-available con la configuración para levantar odoo y después cree un link simbolico al site-enable, este es el archivo de configuración de odoo en nginx:

 

upstream odoo {
    server 127.0.0.1:8069;
}

server {
    listen      443 default;
    server_name odoopin.org;

    access_log  /var/log/nginx/odoo.access.log;
    error_log   /var/log/nginx/odoo.error.log;

    ssl on;
    ssl_certificate     /etc/letsencrypt/live/odoopin.org/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/odoopin.org/privkey.pem;
    keepalive_timeout   60;

    ssl_ciphers "ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS:!AES256";
    ssl_protocols           TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;
    ssl_dhparam /etc/nginx/ssl/dhp-2048.pem;

    proxy_buffers 16 64k;
    proxy_buffer_size 128k;

   

location / {
        proxy_pass  http://odoo;
        proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
        proxy_redirect off;

        proxy_set_header    Host            $host;
        proxy_set_header    X-Real-IP       $remote_addr;
        proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header    X-Forwarded-Proto https;
    }

   

location ~* /web/static/ {
        proxy_cache_valid 200 60m;
        proxy_buffering on;
        expires 864000;
        proxy_pass http://odoo;
    }
}

 

server {
    listen      80;
    server_name odoopin.org;

    add_header Strict-Transport-Security max-age=2592000;
    rewrite ^/.*$ https://$host$request_uri? permanent;
}

 

Que me esta faltando en la conf?

 

Saludos y gracias

 

Fernando Romero
Fernando Romero
7
| 0 0 1
Preguntado en 23-12-18 0:10
0
voto
218 Vistas

Sin duda que hay un conflicto de dominio tiene prioridad la configuración del sistema de iredmail. Fijate el archivo de configuración del "server block" que usa iredmail, debe estar también en el directorio sites-enabled. De no estar allí significa que lo configura en otra parte.

Blanco Martín & Asociados Chile
Blanco Martín & Asociados
1737
| 5 2 5
Respondido en 11-03-19 19:02
0
voto

Su respuesta

Trate por favor de dar una respuesta sustancial. Si quiere comentar en la pregunta o la respuesta, sólo use la herramienta de comentarios. Recuerde que siempre puede revise sus respuestas - no hay necesidad de responder dos veces la misma pregunta. También no olvide votar - ¡ayuda realmente a seleccionar las mejores preguntas y respuestas!

Realizar una pregunta

Mantener informado

Sobre este foro 

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios.

Lea las directrices

Herramientas de las preguntas

77 seguidor(es)

Estadísticas

Preguntado: 23-12-18 0:10
Visto: 218 veces
Última actualización: 11-03-19 19:02