NO puedo conectarme a la base de datos de Postgres en una instalación T16 ?

Hola   Estoy intentando conectarme directamente a la base de datos con pgAdmin 4 desde windows, Odoo esta instalado en una maquina virtua bajo Ubuntu 14 y me da el siguiente error:

could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "192.168.3.121" and accepting
TCP/IP connections on port 5432?

Datos Adicionales:

1) En la shell doeall de inicio de docker de postgres lo tengo

docker run -d --name="postgres" --restart="always" \
-p 5432:5432 \
-v /opt/database:/var/lib/postgresql/data \
-v /var/log/postgresql:/var/log/postgresql postgres:9.4

 

2) Al mirar el trafico en la targeta de red al momento de la coneccion

 tcpdump -i enp0s3 port 5432 -A

me entrega:tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp0s3, link-type EN10MB (Ethernet), capture size 262144 bytes
17:55:17.076953 IP 192.168.3.150.17899 > 192.168.3.121.postgresql: Flags [S], seq 2643271933, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
[email protected]@._........yE..8.. ....... .................
17:55:17.077006 IP 192.168.3.121.postgresql > 192.168.3.150.17899: Flags [R.], seq 0, ack 2643271934, win 0, length 0
E..(%[email protected]@......y.....8E....... .P.......
17:55:17.579446 IP 192.168.3.150.17899 > 192.168.3.121.postgresql: Flags [S], seq 2643271933, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
[email protected]@._........yE..8.. ....... .................
17:55:17.579486 IP 192.168.3.121.postgresql > 192.168.3.150.17899: Flags [R.], seq 0, ack 1, win 0, length 0
E..(%[email protected]@..|...y.....8E....... .P.......
17:55:18.081283 IP 192.168.3.150.17899 > 192.168.3.121.postgresql: Flags [S], seq 2643271933, win 8192, options [mss 1460,nop,nop,sackOK], length 0
[email protected]@._........yE..8.. .....p. .............
17:55:18.081332 IP 192.168.3.121.postgresql > 192.168.3.150.17899: Flags [R.], seq 0, ack 1, win 0, length 0
E..(&[email protected]@..8...y.....8E....... .P.......

 

Gracias

Richard Alejandro Calderon Yañez
Richard Alejandro Calderon Yañez
10
| 1 1 1
Preguntado en 30-09-16 20:57
0
voto
3802 Vistas

Lo mejor es conectar a la base de datos mediante un tunel ssh:

Desde Linux:

ssh -L 5434:localhost:5432 [email protected]

Desde Windows, con putty lo puedes hacer.

Luego en pgadmin creas la conexión a localhost:5434. 

De esta forma, no tienes que modificar la configuración del contenedor docker de postgres.

 

 

Blanco Martín & Asociados Chile
Blanco Martín & Asociados
1737
| 5 2 5
Respondido en 05-10-16 15:00
2
voto

Hola richard creo que ese mensaje de error te sale por que no le as dado permisos al postgres para resivir conexiones desde la red externa revisa si tu archivo /etc/postgresql/version_pogres/main/pg_hba.conf no este bloqueando las conxiones a la red de donde estas tratando de conectarte. un ejemplo deberias tenerlo mas menos asi

 

host    all         all         0.0.0.0/0        md5 ----> de esta forma estarias aceptando cualquier red

es mas seguro poner tu red ej:

host    all         all         192.168.1.0/24        md5

 

Francisco Lorca
Francisco Lorca
27
| 0 0 0
Respondido en 02-10-16 18:36
1
voto

Probe las dos obciones pero solo me funciono haciendo un tuneling.

gracias con eso me sirve

Richard Alejandro Calderon Yañez
Richard Alejandro Calderon Yañez
10
| 1 1 1
Respondido en 19-10-16 23:19
0
voto

Su respuesta

Trate por favor de dar una respuesta sustancial. Si quiere comentar en la pregunta o la respuesta, sólo use la herramienta de comentarios. Recuerde que siempre puede revise sus respuestas - no hay necesidad de responder dos veces la misma pregunta. También no olvide votar - ¡ayuda realmente a seleccionar las mejores preguntas y respuestas!

Realizar una pregunta

Mantener informado

Sobre este foro 

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios.

Lea las directrices

Herramientas de las preguntas

35 seguidor(es)

Estadísticas

Preguntado: 30-09-16 20:57
Visto: 3802 veces
Última actualización: 19-10-16 23:19