FATA[0000] Error response from daemon: Cannot create container with more than 127 parents

Despues de seguir todos los pasos y la llegar al paso de descargar la imagen para correrla tiro el error.

 docker run -d  -v /opt/odoo/extra-addons:/mnt/extra-addons -p 8069:8069 --name odoo --link postgres:postgres -t bmya/odoo-bmya:t22
FATA[0000] Error response from daemon: Cannot create container with more than 127 parents

 

[email protected]:~# docker info
Containers: 1
Images: 159
Storage Driver: devicemapper
 Pool Name: docker-8:0-124739-pool
 Pool Blocksize: 65.54 kB
 Backing Filesystem: extfs
 Data file: /dev/loop0
 Metadata file: /dev/loop1
 Data Space Used: 3.53 GB
 Data Space Total: 107.4 GB
 Data Space Available: 26.28 GB
 Metadata Space Used: 8.966 MB
 Metadata Space Total: 2.147 GB
 Metadata Space Available: 2.139 GB
 Udev Sync Supported: true
 Data loop file: /var/lib/docker/devicemapper/devicemapper/data
 Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
 Library Version: 1.02.77 (2012-10-15)
Execution Driver: native-0.2
Kernel Version: 4.8.6-x86_64-linode78
Operating System: Ubuntu 14.04.5 LTS
CPUs: 1
Total Memory: 1.95 GiB
Name: ubuntu
ID: 6TW4:BUXE:FXED:TU4U:URJ3:YYT4:7WDH:Z6HM:JZ7W:4RZH:4VPF:WCXF

Es una maquina nueva instalada solamente para instalar odoo para pruebas, tambien probe con bmya/odoo-bmya:lastet y el mismo problema por lo que estuve investigando  el problema estaria en la construcción de la imagen. 

si me pueden ayudar. gracias

 

 

cristian zepeda
cristian zepeda
8
| 0 0 0
Preguntado en 17-02-17 20:24
0
voto
1541 Vistas

Amigo a mi me paso lo mismo, para solucionar el problema yo simplemente cambie la version de docker. Si estan en linux prueba con

sudo apt-get update

sudo apt-get install docker.io

La otra solucion (el camino largo y torturoso ) es editar el fichero de configuracion del docker. 

Cualquier cosa me consultas, exito, saludos.

Rene Olivo
Rene Olivo
29
| 2 1 2
Respondido en 21-02-17 14:32
0
voto

Amigo a mi me paso lo mismo, para solucionar el problema yo simplemente cambie la version de docker. Si estan en linux prueba con

sudo apt-get update

sudo apt-get install docker.io

La otra solucion (el camino largo y torturoso ) es editar el fichero de configuracion del docker. 

Cualquier cosa me consultas, exito, saludos.

Rene Olivo
Rene Olivo
29
| 2 1 2
Respondido en 21-02-17 14:32
0
voto

Su respuesta

Trate por favor de dar una respuesta sustancial. Si quiere comentar en la pregunta o la respuesta, sólo use la herramienta de comentarios. Recuerde que siempre puede revise sus respuestas - no hay necesidad de responder dos veces la misma pregunta. También no olvide votar - ¡ayuda realmente a seleccionar las mejores preguntas y respuestas!

Realizar una pregunta

Mantener informado

Sobre este foro 

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios.

Lea las directrices

Herramientas de las preguntas

51 seguidor(es)

Estadísticas

Preguntado: 17-02-17 20:24
Visto: 1541 veces
Última actualización: 21-02-17 14:32